Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Help - No sound from certain stops of Rodgers Scarborough 110

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Darth-Car
    replied
    Plus just to keep it all really simple. Double check all of your wiring connections, both those from the organ to the amp, and then from the amp to the organ. You had something that worked, and now it does not work. That could be a real sign that a connection has just come loose.

    Leave a comment:


  • Leisesturm
    replied
    Originally posted by toodles View Post
    Make sure the speaker wires are connected to the Yamaha, and make sure there isn't a switch on the Yamaha that turns off one channel or one set of speakers. Some amplifiers have A & B speaker switches, and if one speaker is on A and the other on B, you'd have to have both A & B speakers switched in to get both channels.
    There are. Immediately to the right of the power button. My amp is set up exactly the same way. The LED above at least one of those buttons should be lit, since there is clearly power going to the amp. Great/Swell/Pedal have no real meaning on small analog organs. Diapason, Flute, String, etc. yes. Likely some kind of simple mixer was used to combine things. The Great Division has no String, Celeste or Reed voices so if that channel is dead you wouldn't get any Great voices. The speaker wires are probably those tiny guilotine things and they do come loose. Check them as Toodles advises. They should not be wired so that one speaker is on A and the other on B. They should be wired so that one speaker is A, Right and the other speaker is A Left. And of course the A button on the amplifier should be in so its LED lights.

    Leave a comment:


  • toodles
    replied
    It is difficult to guess what is wrong because you are using an approach to the audio system that isn't standard for the Rodgers organ.

    The simplest thing I can suggest to try to identify the problem is to swap the left and right inputs to the Yamaha amplifier; if the missing sound comes back and other sound goes away then it's probably something wrong with the Yamaha or speakers.

    Make sure the speaker wires are connected to the Yamaha, and make sure there isn't a switch on the Yamaha that turns off one channel or one set of speakers. Some amplifiers have A & B speaker switches, and if one speaker is on A and the other on B, you'd have to have both A & B speakers switched in to get both channels.

    Leave a comment:


  • andyg
    replied
    Moved to the correct section of the Forum. Home Organs is for entertainment style organs only. You'll get more response here!

    Leave a comment:


  • seamaster
    replied
    You need to ask the classical crowd. They hang out here.

    Leave a comment:


  • Help - No sound from certain stops of Rodgers Scarborough 110

    I wonder if someone can help me. I am a professional pianist and took up pipe organ a couple of years ago and have happily worked my way to around Grade 8, AMus level and love learning the big works, especially the Bach Trio sonatas. We purchased a Rodgers Scarborough 110 from a Geelong Church some time ago as a home practice organ and were reliably assured that this was the model with internal speakers – imagine our surprise and theirs when we discovered it wasn’t. Rather than spend more money on something that may or may not have suited my needs, my partner, with some advice, rigged up a system using a Yamaha amplifier and 2 large stereo speakers and a small box which I believe allowed him to put 2 channels together – I will attach a photo as I don’t know what it’s called. I also believe that the Pedal and Swell were combined and the Diapason and Flutes were the other combination. This appeared to work but recently I have not been getting any sound from the Great Stops and only getting certain stops on the pedals and swell to sound. I am getting sound on the 16ft pedals: Principal, Bourdon, Leiblich Gedeckt and Fagotto and on the Swell, the 8 ft stops: Salicional, Voix Celeste, Trumpet and Oboe but none of the others and nothing on the Great. I am sure that this is something simple but not sure where to start looking and as I have no clue and my partner is always too busy to investigate I wondered if anyone can point us in the right direction. Also what would be the best way to move forward with this project without spending lots of time and money – I am only interested in playing classical organ. Thanks for your help.
    Attached Files
Working...
X