Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

M3 low volume pedals

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • M3 low volume pedals

    Hi!
    I recently got an M3, great little organ, and all seems to be in good working order except the pedals which seem a very low volume. To get a sensible balance with the pedals and the manuals, I have to have the drawbars for the manuals no louder than 3 or 4. Does this sound right? Can someone give me some pointers please as to how to trouble shoot this?

    Many thanks!

    Matt

  • #2
    Pedal Drawbar out? The pedals have their own preamp consisting of V10 6BA6 tube then the signal is routed out terminal Y to the Drawbar and back to terminal D of the preamp.
    Try adjusting pedal cutoff on preamp?
    If you remove the TWG cover, there are 2 resistors on the back which control Bass pedal volume. If the wire that is connected between them is broken, pedal volume will default to soft.

    Jim

    Comment


    • #3
      Thanks a lot for the info Jim!
      Yes Pedal drawbar is all the way out - I took a look at the 2 resistors and they seem ok - but the 6BA6 tube was covered in oil.... maybe in transport or something, some of the generator oil spilled on it? Anyway - I dont know if the valve is dead / tired, or if some oil is sitting in the valve contacts on the amp. I guess I should try a new valve (hmm where does one get valves these days.... its been a while for me!) and maybe take the amp out and try and clean any oil that may be inside?
      Many thanks
      Matt

      Comment

      Working...
      X