Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Malfunctioning M111 with an Explosive Sound

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Malfunctioning M111 with an Explosive Sound

    Recently I picked up an M100 from a woman selling it for cheap. I was scared to take it home since the tone wheel lock-screws were missing for all but two, but we drove home slowly.
    When I finally got it in I went to see if the motors at least ran before I oiled it and it sounded good all until I finished the start motor and went for the run. It made a loud pop and everything quiet, or at least the starter motor, though the orange LED was lit.
    Now, the starter is completely dead (No noise heard at least) and flipping the run switch causes an explosion noise to come from the internal speakers which is not affected by the expression pedal in any way. I opened the thing up and found a few screws missing, though no caps or wires seemed popped/fried.
    I am currently dumbfounded, as this is my first "real" Hammond that I'm left on my own with, I'm honestly pretty clueless to what may be causing this.

    P.S.
    I have tested the axle for the TWG and it moves smoothly, though the preset tabs have a lot of friction behind them, any fix?
    I haven't tried running it since besides a few tests on the source of the very loud "booms" from the organ, which I quickly turned off [the organ] after hearing.

    Thanks in advance for any advice.

  • #2
    Hi, welcome to the forum and congrats on your acquisition,
    if indeed the start motor doesn't work, IMHO that's what you should troubleshoot first. Inspect all the wires, the switch,etc. Hopefully someone else will chime in.
    A100, X77, M3, M100, E100
    Leslie 147, 145, homemade road Leslie
    My youtube channel

    Comment


    • #3
      I agree - get the TWG running first. Remove the rectifier valves from the AO-29 (5U4) and AO-44 (EZ-81) amps. This will allow you to focus on the TWG. Do you have a meter?

      Jim

      Comment

      Working...
      X