Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Draw Bar Issue?

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Draw Bar Issue?

    Lets see if I can describe this to all of you. On one of the draw bar sets, I pull out the first 3 draw bars and everything is good. I pull out the 4th, and hear what I perceive to be extreme cross-talk and the overall volume of the combined draw bars goes down. I push it back in and volume returns noise goes away. Pull out the 5th draw bar and the same thing happens. Now I pull out both the 4th and 5th together and the volume increases like it should and all cross-talk (maybe not) is gone from the sound? Thoughts and ideas? Could this be a grounding issue? A bad or dirty draw bar contact? It doesn't happen anywhere else on the organ. This just started to happen recently.

    Along with that, When playing the organ for 30 minutes or more, it has popped a circuit breaker a couple of times on my downstairs panel. Related?

    Thanks for your time.
    1964 A-122 / 21H
    XK1-C / Neo Ventilator

  • #2
    Could be dirty DB contacts or loose connections on the preset panel. The signal path is from the manual bussbars to the preset keys to the matching transformer. The DB path adds from the DB select key to the DB's then the DB buss bars to the matching transformer. In both cases the preset panel is a junction point. Check the connections on the right of each preset panel (the ones with the eyelets).

    Jim

    Comment


    • #3
      Thanks Jim. I'll look at the preset panel. I had her opened up for a bus bar cleaning 3 months ago and perhaps one of the screws weren't tightened down all the way. Hopefully this is a quick fix. I will let you know.
      1964 A-122 / 21H
      XK1-C / Neo Ventilator

      Comment

      Working...
      X