Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

BCV swell wiring doesn't mach drawing

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BCV swell wiring doesn't mach drawing

    Click image for larger version

Name:	0527181430.jpg
Views:	2
Size:	119.2 KB
ID:	615189Click image for larger version

Name:	0624181050.jpg
Views:	1
Size:	92.5 KB
ID:	615190

    Will it work like this? I'm missing the coil and a resistor. Also, only 6 connections on top instead of 8. Looks like an incomplete upgrade maybe? What gives? The preamp is being checked out because it wasn't working. The organ works when i line out from the swell with a 1/4".
    BCV, C2, M3, C3
    HR40, 142, 760, 771
    Once upon a time I was a musician, now I just collect Hammonds!:->

  • #2
    You have the stock BC rheostat box. Go back one page in the manual to page 2-29.
    Current organs: AV, M-3, A-100
    Current Leslies: 22H, 122, 770

    Comment


    • #3
      So it won't work like this, correct Enor?

      - - - Updated - - -

      Originally posted by enor View Post
      You have the stock BC rheostat box. Go back one page in the manual to page 2-29.
      It has vibrato added. Did they forget to add the new swell box?
      BCV, C2, M3, C3
      HR40, 142, 760, 771
      Once upon a time I was a musician, now I just collect Hammonds!:->

      Comment


      • #4
        I can't see why it wouldn't work. The rheostat box isn't involved in the vibrato at all - the main difference between the two versions is that the one you have (the BC one) has a few bits in it that are involved in the _tremulant_ circuit... that's the vertical strip on the left that's been disconnected from your box. Rightfully so, since you no longer have the tremulant.

        - - - Updated - - -

        Oh, and in what way was your amp not working? You know it needs an external source of B+ voltage, right? (It does not have its own complete power supply)
        Current organs: AV, M-3, A-100
        Current Leslies: 22H, 122, 770

        Comment


        • #5
          Originally posted by enor View Post
          I can't see why it wouldn't work. The rheostat box isn't involved in the vibrato at all - the main difference between the two versions is that the one you have (the BC one) has a few bits in it that are involved in the _tremulant_ circuit... that's the vertical strip on the left that's been disconnected from your box. Rightfully so, since you no longer have the tremulant.

          - - - Updated - - -

          Oh, and in what way was your amp not working? You know it needs an external source of B+ voltage, right? (It does not have its own complete power supply)
          The preamp was buzzing/humming with no organ sound getting through. My mentor verified the preamp does work via a swap-out with his A. While he has it he is replacing caps and resistors that are failing. I've checked my 6 pin cord for shorts, everything seems ok. We're using an HR 40 for the B plus.
          BCV, C2, M3, C3
          HR40, 142, 760, 771
          Once upon a time I was a musician, now I just collect Hammonds!:->

          Comment


          • #6
            We'll keep at it and post it up when we get her going!
            BCV, C2, M3, C3
            HR40, 142, 760, 771
            Once upon a time I was a musician, now I just collect Hammonds!:->

            Comment

            Working...
            X