Announcement

Collapse
No announcement yet.

Lowrey D325 Help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lowrey D325 Help

    Hi
    If you are familiar with the D325 it has a preset called symphonic wow.
    Everything on this old organ works just fine but that and I would like to repair it.
    I have looked at the attack and decay signal and it looks like it's working just
    fine on the scope but it does not effect the wow voice when you adjust the
    the Range and Attack sliders even though the attack and decay signal is
    changing like it should.

  • #2
    OK. So I assume you have a sound, just not the wow sound.
    On board H there is a circuit consisting of IC1, IC2, Q1 and Q2.
    This is the wow filter. The control voltage goes to this circuit.
    IC 1 and 2 is a CA3080. This is a Transconductance Op-amp and they are known to fail.
    IC 3 and 5 on the same board are the same part so you could swap them with 1 & 2 and see if anything changes.
    Q3 turns the wow sound on and off. IC4 is the output preamp buffer.

    Geo

    Comment


    • #3
      Originally posted by geoelectro View Post
      OK. So I assume you have a sound, just not the wow sound.
      On board H there is a circuit consisting of IC1, IC2, Q1 and Q2.
      This is the wow filter. The control voltage goes to this circuit.
      IC 1 and 2 is a CA3080. This is a Transconductance Op-amp and they are known to fail.
      IC 3 and 5 on the same board are the same part so you could swap them with 1 & 2 and see if anything changes.
      Q3 turns the wow sound on and off. IC4 is the output preamp buffer.




      Geo
      Hi geoelectro
      Yes you are right on and yes the sound is there without wow.
      The attack and delay signal I talked about goes into
      the gain control of those ic's and I was looking there with the scope.
      I hadn't seen those ic's fail with out going into distortion of some sort.
      I will have to try a couple new ones.
      Jim

      Comment


      • #4
        Hi I have a Lowery Holiday D325 works fine except for Symphonic WOW. The attack and range sliders changes the controlling waveform as expected to pin 5
        of the two IC1 and IC2 (CA3080E) Op Amps. They putting out the proper signal but they do not WoW no matter where the attack and range sliders are set.
        All voltages are correct to the service manual.

        Yes I am the one you helped repair the old Wurlitzer omni 6000 I have to telol you thank you and I got it repaired and I just love that
        old organ The rhythm on and accompaniment on it is just what i needed to make my playing sound good.

        Comment

        Working...
        X