Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Roland 900 Display Problem

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest
    Guest replied
    Thank you for your suggestion. The technician arrived and at first the display screen worked after me leaving it dormant for a week. Then the screen locked up for the technician. They dismantled the top and front of the organ to reveal the circuit boards. They removed a connector from LCD display to the circuit board. There is a thin sleeve that covers the connector and they repositioned the sleeve and connector and refastened the connector to the circuit board. Thankfully it worked. I have been testing the display screen every day for a month and it continues to respond. Technician says if this fails again I probably need to replace the entire LCD kit. The cost is around $400. Again, thanks for your response.

    Leave a comment:


  • AtelierMan
    replied
    Did you try to recalibrate your Touch Screen? From the MAIN SCREEN hit SYSTEM/UTILITIES/TOUCH SCREEN. You will get a Blue Screen with a lot of small white dots. The corners will have larger White that appear in the corner. Touch one and another will appear in another cornner. Continue with all 4 corners and the screen will return to the SYSTEM SCREEN. Touch EXIT and you will return to the MAIN Screen. Your display will now be calibrated and hopefully works fine.

    Jeff

    Leave a comment:


  • Guest
    Guest started a topic Roland 900 Display Problem

    Roland 900 Display Problem

    I am a new member and this is my first post. The Main Display screen on my AT 900 is "locking up". In other words it is not responding to any finger touch. I did a factory reset initially and the problem was corrected for a few days and then the "lock out" started again. One technician via phone said it was software problem, but a more experienced technician who is arriving Monday says it is a hardware problem. Has anyone experienced this problem? Can update thread after diagnosis on Monday. Thanks for your interest.
Working...
X