Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Leslie 130 stopped workin

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Leslie 130 stopped workin

    I have a Leslie 130 that wouldn't switch to fast so I took the bottom off pulled the amp out so I could get to the motor and I oiled it. Now it won't even turn on I see nothing unplugged from the amp or back panel unless the motor getting unplugged would cause this because I can't see the back side of the motor and I did take the wingnut loose for the motor. I know it's getting power cause the amp shocked me a couple of times ( I know should have unplugged before working on it southerners never learn)

  • #2
    Have you had any luck? My 130 had trouble when I first got it - sometimes I wouldn't get one of the speeds, sometimes I wouldn't get either speed. In my case it turned out to be nothing electrical, the motors just needed a good oiling and adjustment. Took a few tries with the adjustments, but I finally got it. Check out http://bentonelectronics.com/servici...leslie-motors/, this page is indispensable for Leslie motor maintenance.
    Farfisa Mini Compact V1, Fender Rhodes 73 Mk. 1, Hammond B2, Hammond L-102 "El Choppo", Hammond M-101, Hohner Cembalet CF, Hohner Cembalet N, Hohner Favor Combo, Hohner Pianet L, Hohner Pianet T, Hohner Symphonic 30N, Leslie 145, Leslie "430" (former 130 cab with horns and light show added), Nord Electro 3, and an entire village of guitars and harmonicas.

    Comment


    • #3
      check the simple things first in my case the cable came unplugged from the back of the organ also I know the selector switch is bad.

      Comment

      Working...
      X