Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Technics SX G7

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Technics SX G7

    I was asked to look at a Technics SX G7. The obvious fault is that the display no longer works. Both large IC's on the back of the display board are quite hot to touch.

    If no data pack is inserted the Tab voicing is very strange, but all other sound groups work perfectly .

    The owner has a data pack which seems to have useful registrations in Banks 1& 2. Once either of these banks are loaded the Tab voice functions seem to work perfectly.

    The owner is happy I have been able to show them how to use the organ in its current state.

    Would anyone by chance have a replacement display board from one of these that may have been broken up for parts?
    Any thoughts on how likely it will retain its current function?

    Thank you
    Rick Whatson
    Brisbane - Queensland - Australia
    http://tcptechnology.com.au/

  • #2
    Greetings

    Originally posted by greenfox4075 View Post
    I was asked to look at a Technics SX G7. The obvious fault is that the display no longer works. Both large IC's on the back of the display board are quite hot to touch.

    If no data pack is inserted the Tab voicing is very strange, but all other sound groups work perfectly .

    The owner has a data pack which seems to have useful registrations in Banks 1& 2. Once either of these banks are loaded the Tab voice functions seem to work perfectly.

    The owner is happy I have been able to show them how to use the organ in its current state.

    Would anyone by chance have a replacement display board from one of these that may have been broken up for parts?
    Any thoughts on how likely it will retain its current function?

    Thank you
    I had an organ come in with the same problem but it wasn't the center display board. The upper left registration board has a weak spot. The wire connector on the far left top of the left upper registration board board has a problem with a weak solder joint. The weight of the wire causes the solder joints to break loose from the board with age. I resoldered the bad joints and the center display board and upper registration sounds came back to life. Hope that helps. If not, contact me at [email protected] and I will help you further.

    Comment


    • #3
      Thanks Joe.
      Rick Whatson
      Brisbane - Queensland - Australia
      http://tcptechnology.com.au/

      Comment


      • #4
        This instrument is in a church. The organists have said that on occasions it will drift in its tuning by about a semitone and become unplayable with the piano.

        They rang me today and said the tuning had dropped again last weekend. They have been back and tried it again and it is still out of tune. Apparently it sometimes corrects its self.

        Is anyone aware of these units going out of tune?
        I know there are tuning adjustments, but the organists say they never touch these.

        Any thoughts would be appreciated.

        Regards
        Rick
        Rick Whatson
        Brisbane - Queensland - Australia
        http://tcptechnology.com.au/

        Comment

        Working...
        X