Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Technics SX-E55 Diagnostic Mode Help

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • andyg
    replied
    Hmm, I remember doing that when I had an E55 at home for a while. I can't remember the key presses.

    If no-one on here knows the answer, then you you could join the Vintage Organ Group on Facebook. We have plenty of Technics owners there, including their one time UK boss! He might well remember, I think.

    Leave a comment:


  • Guest
    Guest started a topic Technics SX-E55 Diagnostic Mode Help

    Technics SX-E55 Diagnostic Mode Help

    I have a Technics E55 which I've had since it was new in the mid 80s. When it was purchased, the factory rep showed me a trick to access a few extra sounds which were not native to the E55, but were standard on the E66. The sounds were Flute, Trumpet, and Wha Brass. When these sounds were initially recalled, they were contained in default programs. From there, you could modify the programs and save just as you normally would. There are no buttons for these instruments on the E55, so when they were in use, none of the lights would appear in those sections, yet the sounds were being produced.

    Something happened recently where all my saved programs were wiped out, so now I have no way of accessing these hidden E66 sounds.

    I was able to contact the Technics factory rep, whom I have not spoken to for over 30 years. He could not remember the exact sequence of buttons to recall the hidden E66 sounds. He described it as "diagnostic scanning mode". He thinks I could recover the sounds by trial and error, once I put the organ into this special mode. He said all the lights would blink repeatedly, when the instrument was in the diagnostic mode.

    I have reviewed the manual, and service manual for the E55. No information is contained regarding the diagnostic model function. Does anyone know how to preform this action? I would love to have the hidden sounds again.
Working...
X