Announcement

Collapse
No announcement yet.

Electone BK-5C rescue attempt

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Electone BK-5C rescue attempt

    Hi there

    Noob here, hoping to receive some kind advice - sorry..!

    I have spent a fair few hours over the past couple of weeks, unsuccessfully looking for answers on this forum and beyond.
    Basically : Yam Elec BK-5C, Recently brought out of unloved storage.
    It does power up and the rotary spins keenly!
    It makes a barely audible sound, which is also replicated in headphones and aux line input (music from phone) - the volume pot has no affect, the pedal does however silence the pathetic output. The 'barely audible' sound intermittently becomes loud, but dirty (again independent of vol pot) on certain keys only - which gives the impression that the amp and main speaker are both at least partly functional. The rhythm section and bass pedals do not generate any sound whatsoever.
    Have had the back panel off and removed a collection of dust and cobwebs. Have not yet removed the keybed section, which I'm sure could benefit from a clean too.

    I basically know nothing about Organs but would like to attempt to rescue this one. It went into storage around 8 yrs ago - fully functional and pristine. Came out dirty, a bit battered and dysfunctional!

    I have no idea where to start really, I thought maybe amplifier - the 4 fuses I could see all looked to be in tact.

    My electronics knowledge is pretty limited, but I am willing to invest a little time and money to restore this instrument if possible.

    I would really appreciate an experienced opinion and possibly a pointer towards a service manual for this machine.

    Thanks

    #2
    Hi, I have the same organ with same problem. It has an uneven buzzing noise ... both in headphone and speaker. Did u find any solution? Thanks.

    Comment

    Working...
    X