Forum Top Banner Ad

Collapse

Ebay Classic organs

Collapse

Announcement

Collapse
No announcement yet.

Galanti no sound

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Galanti no sound



    My Church has a Galanti Praeludium II that is about 15 years old. It powers up but makes no sound when the keys are depressed. Any ideas about where to start looking or where schematics could be acquired would be greatly appreciated.</p>

    Thanks,</p>


    TBP
    </p>

  • #2
    Re: Galanti no sound



    We need more info.</p>

    Do the tabs light up?</p>

    Are there external amps and speakers, or are you only running internal speakers?</p>

    Jeff</p>

    Comment


    • #3
      Re: Galanti no sound



      Yes,</p>

      </p>

      All the tabs light up. We are running external speakers. All the power supply fuses are good. The speakers do "pop" slightly when plugging into the external output. It seems that no audio output is being directed to the speakers.</p>

      </p>

      Thanks,</p>

      </p>

      TBP</p>

      Comment


      • #4
        Re: Galanti no sound



        Hi,</p>

        Anything plugged into the headphone jack?</p>

        Have you tried headphones?</p>

        AV
        </p>

        Comment


        • #5
          Re: Galanti no sound



          I have not tried headphones. I will check to see if anything is plugged into that jack tonight.</p>

          Thanks,</p>

          </p>

          TBP</p>

          Comment


          • #6
            Re: Galanti no sound



            Have you tried the internal speakers?</p>

            If your external speakers are running from the 1/4 " jacks on the back of the console, unplug those and try running a line from the 2 rca jacks on the front left control panel (under the left of the keyboards) . My Galanti had a relay that went bad, I had internals and the headphones and RCA jacks worked but the 1/4" jacks didn't.</p>

            Jeff</p>

            </p>

            Comment


            • #7
              Re: Galanti no sound



              Yes, a church here has one of those... I have worked on it... Due to the construction, it is scary!!!</P>


              Previous techs broke the ends off the circuit board connectors... bad news... centering the boards is really tough when the ends are broken out. BE VERY careful if you pull any boards out...</P>


              The audio goes from the digital section over to the power amps on a ribbon cable...</P>


              The circuit boards in the one here have solder-plated connections rather than goldon the boards and those are totally unreliable...</P>


              You might try rocking the boards to and fro (NOT SIDEWAYS lest you break the connector ends. You have to taake the retaining strap off.</P>


              Make sure some of the tabs are set as no tabs, no sounds... Do the lights on the tabs work? Try the pistons... do they work?</P>


              Try the headphone jack...</P>


              Schematics? Non existent... and Galanti, now Alhborn Galanti closed down their user tech forum and it is only available to their service people...</P>
              <P mce_keep="true"></P>

              Comment

              Working...
              X